Is the best Scala convention to invoke collection.size or collection.length [closed] - scala

Closed. This question is opinion-based. It is not currently accepting answers.
Want to improve this question? Update the question so it can be answered with facts and citations by editing this post.
Closed 9 years ago.
Improve this question
I understand these two methods are identical (one is defined in terms of the other) according to this previous question:
Scala Buffer: Size or Length?
But is there a reigning best practice or recommended convention? I can think of three options:
(1) Always use size
(2) Always use length
(3) Use size for all collections exception Array
I'm leaning towards (1) or (3). The rationale behind (3) is that these methods are inherited from Java. And in Java you'd be invoking collection.size() and array.length. The argument for (1) is that it builds on and simplifies (3). The argument for (2) I'm not really sure about.

They are the same. It makes no difference. Use whatever you want.

Related

Spark optimized coding [closed]

Closed. This question is opinion-based. It is not currently accepting answers.
Want to improve this question? Update the question so it can be answered with facts and citations by editing this post.
Closed 1 year ago.
Improve this question
I am newbie in pyspark. In the following ways of the writing the code:
1st way:
s_df= s_df.withColumn('sum', s_df['Col1'] + s_df['Col2'] )
s_df= s_df.withColumn('difference', s_df['Col1'] - s_df['Col2'] )
2nd way:
s_df= ( s_df.withColumn('sum', s_df['Col1'] + s_df['Col2'])
.withColumn('difference', s_df['Col1'] - s_df['Col2']) )
It is always advisable to use the second one, this has to do something with how spark works internally. Can anyone please give me a detailed reason for this?
There is no difference between those 2 "ways" as you describe it, as #mck points out, s_df.explain() will be the same for both cases.
I don't think there is an official or "advisable" way to write code, as Spark doesn't provide any style guidelines in its document. However, I find it's easier writing it this way (more readable and maintainable)
s_df = (s_df
.withColumn('sum', s_df['Col1'] + s_df['Col2'])
.withColumn('difference', s_df['Col1'] - s_df['Col2'])
)
Also, it's worth mentioning that even though it's totally legitimate to override s_df, but you will lost your original dataframe which you probably will need it later.

Are there copy constructors in Swift structures? [closed]

Closed. This question needs details or clarity. It is not currently accepting answers.
Want to improve this question? Add details and clarify the problem by editing this post.
Closed 2 years ago.
Improve this question
It's known, that when assigning an instance of structure to another instance, or passing it to a function, Swift essentially copies the instances by value. However I could not find anywhere if we actually have control over this process, like in C++ copy constructors. My question is whether Swift has analogue to C++ copy constructors and if not, are there anything in the language what helps to take control over passing-by-value process in Swift?
Copy constructors are implicit in Swift, and can't be user-customized.
They always copy all fields of a struct. For fields that are references to object, copying is defined as the increment of reference count (a retain).

When creating a REST API are there any naming conventions for designating a read only property? [closed]

Closed. This question is opinion-based. It is not currently accepting answers.
Want to improve this question? Update the question so it can be answered with facts and citations by editing this post.
Closed 8 years ago.
Improve this question
I was thinking it would be useful if the property name clearly signaled it was readonly.
Take this object as an example:
{
"id":"12154",
"name":"some name",
"email":"email#something.com",
"joinDate":"05/04/2012"
}
id and joinDate are of course properties that are readonly and will not allow a change through a PUT/POST request. Is there some type of convention for marking these as such? I was thinking of doing this with underscores:
{
"_id":"12154",
"name":"some name",
"email":"email#something.com",
"_joinDate":"05/04/2012"
}
There is no naming convention for read-only properties in REST. You should, of course, feel free to establish whatever conventions you like for your own API. As Fiver said in his comment, you should make sure they are clearly documented, or your conventions will be some combination of (a) confusing, and (b) noise.

Is there a Coffeescript equivalent for Dart [closed]

Closed. This question needs details or clarity. It is not currently accepting answers.
Want to improve this question? Add details and clarify the problem by editing this post.
Closed 8 years ago.
Improve this question
The main aspect of CoffeeScript I'd like to see available also for Dart in form of a different, Dart-based language would be less verbosity, less brackets, less Java-style.
Does such solution exist ?
No.
If you don't want to have your field static you can omit the static keyword.
If you don't want to have your field final you can write var or a concrete type instead of the final keyword.
And if you don't want a loop you can omit for, while, forEach, ...

How to list all called methods? [closed]

Closed. This question is off-topic. It is not currently accepting answers.
Want to improve this question? Update the question so it's on-topic for Stack Overflow.
Closed 10 years ago.
Improve this question
Is there any way that I can list all called methods like there are called one after the other? For example now I am doing same thing in way that I'm putting NSLog(#"MethodName"); i every that method.
I want to do that by automatic way in NSLog. Is it possible?
If you don't have too much methods you can use
NSLog(#"%#" , NSStringFromSelector(_cmd));
to log their names. This way you don't have to copy the signatures manually each time.
Create a property 'NSMutableArray *calledMethods;`
And in each of your method use
[self.calledMethods addObject:NSStringFromSelector(_cmd)];
And whenever you want to print it NSLog it.
I think you want:
printf("%s\n", __PRETTY_FUNCTION__ ) ;
Which produces (for example)
-[AppDelegate application:didFinishLaunchingWithOptions:]
Or, you can use dtrace. This answer should help: https://stackoverflow.com/a/3874726/210171.
Also check https://stackoverflow.com/a/4604249/210171 (same linked question). Seems there's an environment variable NSObjCMessageLoggingEnabled you can set...