EBADENGINE warnings while running Apache-Age Viewer - postgresql

So while setting up Apache Age, I ran the command npm run setup and was greeted by the following EBADENGINE warnings.
npm WARN EBADENGINE Unsupported engine {
npm WARN EBADENGINE package: 'ag-viewer#0.0.1',
npm WARN EBADENGINE required: { node: '^14.16.0' },
npm WARN EBADENGINE current: { node: 'v18.14.1', npm: '9.3.1' }
These warnings followed by numerous other warnings of unsupported dependencies.

The warnings say that my Node Version is other than the required one so the obvious solution was to downgrading my node version.
Documentation from the Apache-Age Viewer's Github Repository recommends using Node version - ^14.16.0 i.e., any version greater than or equal to 14.16.0 but less than 15.
First check your current Node Version by typing node -v and I recommend downgrading it if it's not >= 14.16.0 and <15.
Follow this link for help in downgrading node version.
Check your node version again after downgrading and run npm run setup again.
Hopefully, the warnings will be gone!

While one way is to downgrade the node version manually.
Alternatively you can use nvm Node Version Manager (Windows, Mac or Linux)
Then just open a terminal (admin/sudo):
nvm install 14.16.0
nvm use 14.16.0
npm run setup

The error is actually because of the wrong version of the node installed. I also faced the same error when I did the incorrect installation. You can fix it by deleting the nvm and node from your machine and reinstalling the nvm and correct node version. and run npm run setup after the required installation.
Fixing the error:
To fix this error take a look at following steps:
Delete nvm, npm and node and install it all again.
For uninstalling node run following command:
nvm uninstall 14.16.0
The command if executed successfully will return a success message indicating the version of node deleted.
Uninstalled node v13.10.1
Type following command in terminal for the deletion of nvm
#nvm deactivate will remove the path variables
nvm deactivate
#nvm unload will uninstall the nvm
nvm unload
export NVM_DIR="$HOME/.nvm"
[ -s "$NVM_DIR/nvm.sh" ] && \. "$NVM_DIR/nvm.sh" # This loads nvm
[ -s "$NVM_DIR/bash_completion" ] && \. "$NVM_DIR/bash_completion" # This loads nvm
Now the node and nvm is deleted go above and download both of them again and run those commands as well.
npm run setup
npm run start
When you run npm run start, age-viewer will start running on
You will see a screen like this. Enter the details to start using the age-viewer.

For setting up Apache AGE, you do not need to run the command npm run setup.
This for setting up AGE Viewer.
For setting up AGE: https://github.com/apache/age follow the guidelines.
For setting up AGE Viewer: https://github.com/apache/age-viewer follow the guidelines.


npm notice Beginning October 4, 2021, all connections to the npm registry - including for package installation - must use TLS 1.2 or higher

I am getting this warning from github on my npm project build process...
I tried searching on the internet and also read the blog link posted by github - but I could not find the solution to it anywhere. Am I missing something ?
Warning seen
npm notice Beginning October 4, 2021, all connections to the npm registry - including for package installation - must use TLS 1.2 or higher. You are currently using plaintext http to connect. Please visit the GitHub blog for more information: https://github.blog/2021-08-23-npm-registry-deprecating-tls-1-0-tls-1-1/
After updating your NodeJS and NPM Version run this command in CLI
npm set registry=https://registry.npmjs.org/
Save your Life, Thanks me Later :D
I can solve the issue by the way:
First Step: npm set registry=https://registry.npmjs.org/
Second Step: npm install -g https://tls-test.npmjs.com/tls-test-1.0.0.tgz
Besides updating your version of node to an active or current LTS you want to ensure your NPM registry is set to an HTTPS endpoint:
You are facing that issue because your registry is set to HTTP version which is a bit insecure so the first thing that you should do is to put it to HTTPS version by running the following command below
npm set registry=https://registry.npmjs.org/
Then, after that you have to make sure your version of npm supports TLS 1.2, you can install a test package from an HTTPS endpoint that already has TLS 1.0 and TLS 1.1 disabled: by running this command below
npm install -g https://tls-test.npmjs.com/tls-test-1.0.0.tgz
You should see the following message:
Hello! The tls-test package was successfully downloaded and installed. Congratulations! Your package manager appears to support TLS 1.2.
If you don't see the message, don't worry you can try to install the package again, hope it will work out for you
Please make sure that you have latest(or somewhat recent) version of node installed on your system
To make sure that your version of npm supports TLS 1.2, you can install a test package from an HTTPS endpoint that already has TLS 1.0 and TLS 1.1 disabled:
npm install -g https://tls-test.npmjs.com/tls-test-1.0.0.tgz
You should see the following message:
Hello! The tls-test package was successfully downloaded and installed.
Congratulations! Your package manager appears to support TLS 1.2.
If you didn't see the above message, try to install some npm package.
If you didn't see the npm notice, you're good to go. If you happened to see again, please run the below command too.
npm set registry=https://registry.npmjs.org/
Source: The npm registry is deprecating TLS 1.0 and TLS 1.1
You are facing this issue because of your registry is still set to http version and that causing you this error. All You need to do is just Run following command in your terminal.
npm config set registry https://registry.npmjs.org/
and that is it!
now you can run any npm command
Well, I had several problems with node and npm. The one described in this question was only the last one.
I was not able to execute npm install, the node_modules were partially downloaded and at the end of the execution they were all deleted (the folder was visible, but it was deleted after running the command).
First problem: --location=global
First, I was getting this error message:
npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead
Which I solved by following these instructions: https://stackoverflow.com/a/72592742/7389293
Apparently that allowed me to update to:
node -v: c16.16.0
npm -v: 8.17.0
Today's date: August 13, 2022.
Second problem: use TLS 1.2 or higher
Then, I still was having the error described in this question, which didn't allowed me to install the node_modules folder in my project:
npm notice Beginning October 4, 2021, all connections to the npm registry - including for package installation - must use TLS 1.2 or higher
The selected answer to the question made in the present screen your reading, finally fixed the problem: https://stackoverflow.com/a/70555822/7389293
After all of this I was able to run npm again, install all the packages from the package.json file, and run the website normally in the browser.
maxtimeout didn't work for me
so I tried converting to yarn by npm I -g yarn
and then yarn install in the root directory of the project(where I have to install the node_modules)

VS Code Jest fails starting on Ubuntu 20.04 (ubuntu-make install)

Ubuntu 20.04 (official Beta Version)
Visual Studio Code 1.44.2, installed via ubuntu-make (umake):
umake ide visual-studio-code
Node 12 via nvm install 12 && nvm alias default 12 && nvm use default
VS Code Extension: jest
Restarting VS Code fails with:
Finished running all tests. Starting watch mode.
/bin/sh: 1: npm: not found
/bin/sh: 1: npm: not found
Starting Jest in Watch mode failed too many times and has been stopped.
see troubleshooting: https://github.com/jest-community/vscode-jest/blob/master/README.md#troubleshooting
I want to use nvm and want to avoid workaround like adjusting bashrc or similar.
Did not work:
Add to VS Code settings.json (via Ctrl+Shift+P, "Open Settings Json"):
entry "terminal.integrated.shell.linux": "/bin/bash"
Just had an issue running commands over ssh where the node binary from nvm would not be added to the non-login shell's path so couldn't be used. Can't figure out how to add it there and keep it relative to the installed user to be honest.
Removing nvm and installing apt install nodejs through the default repositories is quick workaround if you need.

jspm hot reloading install - command not found after global install

i try to install the hot reload module of jspm using the chokidar-socket-emitter. Installation works like charme, but after that it is not possible to start the watch task as described here: http://jspm.io/0.17-beta-guide/hot-reloading.html
Here is my install log:
XXXXXMacBookPro:dasding xxxxxx$ sudo npm i -g chokidar-socket-emitter
fsevents#1.0.12 install /usr/local/lib/node_modules/chokidar-socket-emitter/node_modules/chokidar/node_modules/fsevents
node-pre-gyp install --fallback-to-build
[fsevents] Success: "/usr/local/lib/node_modules/chokidar-socket-emitter/node_modules/chokidar/node_modules/fsevents/lib/binding/Release/node-v14-darwin-x64/fse.node" is installed via remote
chokidar-socket-emitter#0.3.1 /usr/local/lib/node_modules/chokidar-socket-emitter
├── socket.io#1.4.6 (has-binary#0.1.7, debug#2.2.0, socket.io-parser#2.2.6, socket.io-adapter#0.4.0, engine.io#1.6.9, socket.io-client#1.4.6)
└── chokidar#1.5.2 (path-is-absolute#1.0.0, inherits#2.0.1, glob-parent#2.0.0, async-each#1.0.0, is-binary-path#1.0.1, is-glob#2.0.1, readdirp#2.0.0, anymatch#1.3.0, fsevents#1.0.12)
XXXXXMacBookPro:dasding xxxxxx$ chokidar-socket-emitter
bash: chokidar-socket-emitter: command not found
XXXXXMacBookPro:dasding xxxxxx$
Does anyone has any idea why he is unable to find the command? i have no idea how to fix this, global installs always used to work without any problem.
thanks in advance
Ok, in case someone faces the same problem - my current node.js installation was unable to handle the latest version of chokidar-socket-emitter, so a lower version was installed, but the docs refered to the latest version, so there never was a command that could have been found. after updating my node.js installation everything worked like charme.

Grunt need compass installed in system PATH Warning

I want to install Yeoman, Grunt and bower to my node project.
I made a node project in Eclipse (using the nodeclipse plugin) and navigated to the project folder
(which is H:\Eclipse Workspace\YoTest) in cmd and typed in:
npm install yo -g
npm install generator-webapp -g
yo webapp
selected: Sass (with compass), in cmd
And then typed:
grunt serve
to run the webapp.
I get the following error message:
Done, without errors.
Warning: Running "compass:server" (compass) task
Warnin: You need to have Ruby and Compass installed and in your system PATH for
this task to work. More info: https://github.com/gruntjs/grunt-contrib-compass
Use --force to continue.
Aborted due to warnings. Use --force to continue.
Aborted due to warnings.
How do I fix this so that I can run my node project with grunt?
PS: I'm not sure if it has anything to do with the problem, but I also get the following errors on line 1-27 in my package.json:
Multiple markers at this line
- strings must use singlequote
- strings must use singlequote
This is my package.json
"name": "yotest2",
"version": "0.0.0",
"dependencies": {},
"devDependencies": {
"grunt": "~0.4.1",
"grunt-contrib-copy": "~0.4.1",
"grunt-contrib-concat": "~0.3.0",
"grunt-contrib-uglify": "~0.2.0",
"grunt-contrib-compass": "~0.7.0",
"grunt-contrib-jshint": "~0.7.0",
"grunt-contrib-cssmin": "~0.7.0",
"grunt-contrib-connect": "~0.5.0",
"grunt-contrib-clean": "~0.5.0",
"grunt-contrib-htmlmin": "~0.1.3",
"grunt-bower-install": "~0.7.0",
"grunt-contrib-imagemin": "~0.2.0",
"grunt-contrib-watch": "~0.5.2",
"grunt-rev": "~0.1.0",
"grunt-autoprefixer": "~0.5.0",
"grunt-usemin": "~2.0.0",
"grunt-mocha": "~0.4.0",
"grunt-modernizr": "~0.4.0",
"grunt-newer": "~0.6.0",
"grunt-svgmin": "~0.2.0",
"grunt-concurrent": "~0.4.0",
"load-grunt-tasks": "~0.2.0",
"time-grunt": "~0.2.0",
"jshint-stylish": "~0.1.3"
"engines": {
"node": ">=0.8.0"
I'm on Windows.
The warning seems to say it all.
If you're on OS X or Linux you probably already have Ruby installed; test with ruby -v in your terminal. When you've confirmed you have Ruby installed, run gem update --system && gem install compass to install Compass and Sass.
If that doesn't help, then install the grunt-contrib-compass package with the instructions at https://github.com/gruntjs/grunt-contrib-compass
I struggled for hours with this same error message when running a gulp watch, and despite installing, reinstalling, rebooting, it would still show up.
Got it working by uninstalling all my packages :
sudo gem uninstall bundler bundle compass sass compass-core compass-import-once
And installing bundle only
sudo gem install bundle bundler
And then run the command that magically installed everything I needed :
$ bundle
Fetching gem metadata from https://rubygems.org/...........
Fetching version metadata from https://rubygems.org/..
Installing sass 3.4.9
Installing sassy-maps 0.4.0
Installing breakpoint 2.5.0
Installing hitimes 1.2.2
Installing timers 4.0.1
Installing celluloid 0.16.0
Using chunky_png 1.3.3
Using multi_json 1.10.1
Installing compass-core 1.0.1
Using compass-import-once 1.0.5
Using rb-fsevent 0.9.4
Using ffi 1.9.6
Using rb-inotify 0.9.5
Installing compass 1.0.1
Installing json 1.8.1
Installing listen 2.8.3
Installing thor 0.19.1
Installing fontcustom 1.3.7
Installing modular-scale 2.0.5
Installing normalize-scss 3.0.2
Installing sass-css-importer 1.0.0.beta.0
Installing sassy-buttons 0.2.6
Installing susy 2.1.3
Using bundler 1.8.0
Bundle complete! 9 Gemfile dependencies, 24 gems now installed.
Use `bundle show [gemname]` to see where a bundled gem is installed.
Post-install message from compass:
Compass is charityware. If you love it, please donate on our behalf at http://umdf.org/compass Thanks!
Post-install message from fontcustom:
>> Thanks for installing Font Custom! Please ensure that fontforge is installed before compiling any icons. Visit <http://fontcustom.com> for instructions.
Now, don't ask me why, but it all works :-)
Hope that can help anybody out there, I really struggled on this one ...
Just need to write on console -> (or sudo )gem install compass ,because the npm command wouldn´t do anything
For Mac OS X 10.10 (Yosemite)
Search for installed ruby version
ruby -v.
If present
update gems using sudo gem update --system
else install rvm with ruby using
\curl -sSL https://get.rvm.io | bash -s stable --ruby
Then install the Xcode Command Line Tools
xcode-select --install .
This will take some time.
Now install compass using sudo gem install compass.
For me this worked like a charm.
Ruby and Ruby Gems ought to be installed which in turn facilitate the installation of Sass and compass. Check this out http://hecktechsolutions.blogspot.in/2015/03/installation-of-gems-compass-and-sass.html

How to install protractor and start it?

I followed instructions in the document on how to install protractor and selenium and I am unable to start.
install -g protractor
webdriver-manager update
After that I tried
webdriver-manager start and I got an error
throw er; // Unhandeled 'error event
Error: spawn ENOENT
at errnoException (child_projcess.js:980:11)
at Process.ChildProcess.handle.onexeit (childprocess.js:771:34)
If I do webdriver-manager status I get this
selenium standalone is up to date
chromedriver is up to date
IEDriver is not present
What is going on?
Looks like you are running on the mac platform.
Installing it globally as you are doing, installs it to the system's node_module folder. You should try and install it locally for the project as its a project dependency.
so run:
npm install protractor
Kind of old, but what solved it for me was to install java:
In an Ubuntu system:
sudo apt-get install openjdk-7-jre
In Fedora:
sudo yum install java-1.8.0-openjdk
Keep hacking!
First install globally npm i -g protractor
Secondly install locally npm i protractor